Socket
Socket
Sign inDemoInstall

nuxt-zod-i18n

Package Overview
Dependencies
4
Maintainers
0
Versions
14
Alerts
File Explorer

Advanced tools

Install Socket

Detect and block malicious and high-risk dependencies

Install

nuxt-zod-i18n

A Nuxt Module for localizing zod error messages.


Version published
Weekly downloads
1.2K
decreased by-14.18%
Maintainers
0
Created
Weekly downloads
 

Changelog

Source

v1.9.0

compare changes

🚀 Enhancements

  • Add uk-UA.json (ebef74d)

🩹 Fixes

  • i18n: Template surrounding for uk-UA locale (90da19b)
  • i18n: Small typo in uk-UA locale (243d8df)

❤️ Contributors

Readme

Source

Nuxt ZodI18n

npm version npm downloads License Nuxt

A Nuxt Module for localizing zod error messages.

Check the playground for usage doc and test will come later

Features

Quick Setup

  1. Add nuxt-zod-i18n dependency to your project
npx nuxi@latest module add nuxt-zod-i18n
  1. Add nuxt-zod-i18n to the modules section of nuxt.config.ts before @nuxtjs/i18n module
export default defineNuxtConfig({
  modules: ['nuxt-zod-i18n', '@nuxtjs/i18n']
})

That's it! You can now use Nuxt ZodI18n in your Nuxt app ✨

Development

# Install dependencies
npm install

# Generate type stubs
npm run dev:prepare

# Develop with the playground
npm run dev

# Build the playground
npm run dev:build

# Run ESLint
npm run lint

# Run Vitest
npm run test
npm run test:watch

# Release new version
npm run release

FAQs

Package last updated on 10 Jul 2024

Did you know?

Socket

Socket for GitHub automatically highlights issues in each pull request and monitors the health of all your open source dependencies. Discover the contents of your packages and block harmful activity before you install or update your dependencies.

Install

Related posts

SocketSocket SOC 2 Logo

Product

  • Package Alerts
  • Integrations
  • Docs
  • Pricing
  • FAQ
  • Roadmap

Packages

Stay in touch

Get open source security insights delivered straight into your inbox.


  • Terms
  • Privacy
  • Security

Made with ⚡️ by Socket Inc