Socket
Socket
Sign inDemoInstall

create-require

Package Overview
Dependencies
0
Maintainers
1
Versions
7
Alerts
File Explorer

Advanced tools

Install Socket

Detect and block malicious and high-risk dependencies

Install

Comparing version 0.0.1 to 1.0.0

9

package.json
{
"name": "create-require",
"version": "0.0.1",
"description": "Polyfill for Node.js (<= v12.2.0) module.createRequire",
"version": "1.0.0",
"description": "Polyfill for Node.js module.createRequire (<= v12.2.0)",
"repository": "nuxt-contrib/create-require",

@@ -29,3 +29,4 @@ "license": "MIT",

"release": "yarn test && standard-version && git push --follow-tags && npm publish",
"test": "yarn lint && yarn jest"
"test:matrix": "tap --no-esm --no-timeout ./test/matrix.js",
"test": "yarn lint && yarn test:matrix"
},

@@ -35,5 +36,5 @@ "devDependencies": {

"eslint": "latest",
"jest": "latest",
"tap": "latest",
"standard-version": "latest"
}
}

@@ -8,3 +8,3 @@ # `create-require`

Polyfill for Node.js (<= v12.2.0) [`module.createRequire`](https://nodejs.org/api/modules.html#modules_module_createrequire_filename)
Polyfill for Node.js [`module.createRequire`](https://nodejs.org/api/modules.html#modules_module_createrequire_filename) (<= v12.2.0)

@@ -27,4 +27,5 @@ ## Install

const createRequire = require('create-require')
const require = createRequire('path/to/test.js')
const module = require('./test-sibling-module')
const myRequire = createRequire('path/to/test.js')
const myModule = myRequire('./test-sibling-module')
```

@@ -31,0 +32,0 @@

Sorry, the diff of this file is not supported yet

SocketSocket SOC 2 Logo

Product

  • Package Alerts
  • Integrations
  • Docs
  • Pricing
  • FAQ
  • Roadmap

Stay in touch

Get open source security insights delivered straight into your inbox.


  • Terms
  • Privacy
  • Security

Made with ⚡️ by Socket Inc