Socket
Socket
Sign inDemoInstall

eslint-plugin-this

Package Overview
Dependencies
1
Maintainers
1
Versions
9
Alerts
File Explorer

Advanced tools

Install Socket

Detect and block malicious and high-risk dependencies

Install

eslint-plugin-this

ESLint plugin to disallow the use of 'this'


Version published
Weekly downloads
9.2K
increased by82.56%
Maintainers
1
Created
Weekly downloads
 

Readme

Source

eslint-plugin-this

Build Status Version on npm Known Vulnerabilities

do not allow this

Installation

You'll first need to install ESLint:

$ npm install eslint --save-dev

Next, install eslint-plugin-this:

$ npm install eslint-plugin-this --save-dev

Note: If you installed ESLint globally (using the -g or --global flag) then you must also install eslint-plugin-this globally.

Usage

Add this to the plugins section of your .eslintrc configuration file. You can omit the eslint-plugin- prefix:

{
    "plugins": [
        "this"
    ]
}

Then configure the rules you want to use under the rules section.

{
    "rules": {
        "this/no-this": 2
    }
}

Supported Rules

  • no-this

Thanks

Thanks to Brian Leroux for asking if this existed and Björn Tegelund for basically spelling out how to create an ESLint plugin

Keywords

FAQs

Last updated on 16 Mar 2018

Did you know?

Socket

Socket for GitHub automatically highlights issues in each pull request and monitors the health of all your open source dependencies. Discover the contents of your packages and block harmful activity before you install or update your dependencies.

Install

Related posts

SocketSocket SOC 2 Logo

Product

  • Package Alerts
  • Integrations
  • Docs
  • Pricing
  • FAQ
  • Roadmap

Packages

Stay in touch

Get open source security insights delivered straight into your inbox.


  • Terms
  • Privacy
  • Security

Made with ⚡️ by Socket Inc