Socket
Socket
Sign inDemoInstall

socket.io-parser

Package Overview
Dependencies
5
Maintainers
2
Versions
53
Alerts
File Explorer

Advanced tools

Install Socket

Detect and block malicious and high-risk dependencies

Install

Comparing version 2.3.0 to 2.3.1

7

binary.js

@@ -7,2 +7,3 @@ /*global Blob,File*/

var isArray = require('isarray');
var isBuf = require('./is-buffer');

@@ -31,3 +32,3 @@

return placeholder;
} else if (Array.isArray(data)) {
} else if (isArray(data)) {
var newData = new Array(data.length);

@@ -70,3 +71,3 @@ for (var i = 0; i < data.length; i++) {

return buf;
} else if (Array.isArray(data)) {
} else if (isArray(data)) {
for (var i = 0; i < data.length; i++) {

@@ -126,3 +127,3 @@ data[i] = _reconstructPacket(data[i]);

fileReader.readAsArrayBuffer(obj); // blob -> arraybuffer
} else if (Array.isArray(obj)) { // handle array
} else if (isArray(obj)) { // handle array
for (var i = 0; i < obj.length; i++) {

@@ -129,0 +130,0 @@ _removeBlobs(obj[i], i, obj);

2.3.1 / 2016-10-24
==================
* [chore] Revert "Remove deprecated isarray dependency" (#50)
2.3.0 / 2016-10-21

@@ -3,0 +8,0 @@ ==================

{
"name": "socket.io-parser",
"version": "2.3.0",
"version": "2.3.1",
"description": "socket.io protocol parser",

@@ -17,3 +17,4 @@ "repository": {

"json3": "3.3.2",
"component-emitter": "1.1.2"
"component-emitter": "1.1.2",
"isarray": "0.0.1"
},

@@ -20,0 +21,0 @@ "devDependencies": {

SocketSocket SOC 2 Logo

Product

  • Package Alerts
  • Integrations
  • Docs
  • Pricing
  • FAQ
  • Roadmap

Stay in touch

Get open source security insights delivered straight into your inbox.


  • Terms
  • Privacy
  • Security

Made with ⚡️ by Socket Inc