
Security News
TypeScript is Porting Its Compiler to Go for 10x Faster Builds
TypeScript is porting its compiler to Go, delivering 10x faster builds, lower memory usage, and improved editor performance for a smoother developer experience.
BSDploy is a comprehensive tool to remotely provision, configure and maintain FreeBSD <http://www.freebsd.org>
_ jail hosts and jails <http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/jails.html>
_.
Its main design goal is to lower the barrier to repeatable jail setups.
Instead of performing updates on production hosts you are encouraged to update the description of your setup, test it against an identically configured staging scenario until it works as expected and then apply the updated configuration to production with confidence.
provision complete jail hosts from scratch
describe one or more jail hosts and their jails in a canonical configuration
declarative configuration – apply Ansible <http://ansible.com>
_ playbooks to hosts and jails
imperative maintenance – run Fabric <http://fabfile.org>
_ scripts against hosts and jails
configure ZFS pools and filesystems <https://wiki.freebsd.org/ZFS>
_ with whole-disk-encryption <http://www.freebsd.org/doc/handbook/disks-encrypting.html>
_
modular provisioning with plugins for VirtualBox <https://www.virtualbox.org>
_ and Amazon EC2 <http://aws.amazon.com>
_ and an architecture to support more.
BSDploy takes the shape of a commandline tool by the name of ploy
which is installed on a so-called control host (typically your laptop or desktop machine) with which you then control one or more target hosts. The only two things installed on target hosts by BSDploy are Python and ezjail
– everything else stays on the control host.
Here's what an abbreviated bootstrapping session of a simple website inside a jail on an Amazon EC2 instance could look like::
# ploy start ec-instance
[...]
# ploy configure jailhost
[...]
# ploy start webserver
[...]
# ploy configure webserver
[...]
# ploy do webserver upload_website
Combining a declarative approach for setting up the initial state of a system with an imperative approach for providing maintenance operations on that state has significant advantages:
Since the imperative scripts have the luxury of running against a well-defined context, you can keep them short and concise without worrying about all those edge cases.
And since the playbooks needn't concern themselves with performing updates or other tasks you don't have to litter them with awkward states such as restarted
or updated
or – even worse – with non-states such as shell
commands.
BSDploy's scope is quite ambitious, so naturally it does not attempt to do all of the work on its own. In fact, BSDPloy is just a fairly thin, slightly opinionated wrapper around existing excellent tools.
In addition to the above mentioned Ansible and Fabric, it uses ezjail <http://erdgeist.org/arts/software/ezjail/>
_ on the host to manage the jails and on the client numerous members of the ployground family <https://github.com/ployground/>
_ for pretty much everything else.
The full documentation is hosted at RTD <http://docs.bsdploy.net>
_.
bootstrap-password
option.destroygeom
via bootstrap-destroygeom
.bootstrap-packages
.dst
option to use another file then the default /etc/rc.conf
.bootstrap-host-keys
to bootstrap-ssh-host-keys
.bootstrap-ssh-fingerprints
to allow overriding of ssh-fingerprints
for bootstrapping.bootstrap-files
changed from [playbooks-directory]/bootstrap-files
to [playbooks-directory]/[instance-uid]/bootstrap-files
.firstboot-update
to bootstrap-firstboot-update
to match the other variables.[change] switch to use ploy 2.0.0 and Ansible 2.4.x.
[feature] the fabfile
option is set if [instance-name]/fabfile.py
exists when the more specific [master-name]-[instance-name]/fabfile.py
doesn't exist.
[fix]: honour the boottrap-packages
setting for mfsbsd.
ssh_host_ed25519_key*
files on your host which you might want to copy to your bootstrap files directory alongside the other ssh_host_*_key*
filesbootstrap
to digitalocean
in the ez-master
definitionjails_zfs_root
in the ez-master
definitionzpool
ansible module if the name matcheszpool
ansible module, in case it already exists, only if that fails create it from scratchzpool
ansible moduleploy_jail_host_pkg_repository
variable during bootstrapping (not just jailhost configuration)ploy vault
commands. This is useful for the private ssh host keys in bootstrap-files
.firstboot-freebsd-update <http://www.freshports.org/sysutils/firstboot-freebsd-update/>
_ (disabled by default)ipnat_rules
to the new pf_nat_rules
.fingerprint
option for ezjail master automatically if a ssh host key exists locally.ploy
and ploy-ssh
console scripts.ploy_virtualbox
an optional dependencymr.awsome*
dependencies to ploy*
FAQs
A tool to remotely provision, configure and maintain FreeBSD jails
We found that bsdploy demonstrated a healthy version release cadence and project activity because the last version was released less than a year ago. It has 2 open source maintainers collaborating on the project.
Did you know?
Socket for GitHub automatically highlights issues in each pull request and monitors the health of all your open source dependencies. Discover the contents of your packages and block harmful activity before you install or update your dependencies.
Security News
TypeScript is porting its compiler to Go, delivering 10x faster builds, lower memory usage, and improved editor performance for a smoother developer experience.
Research
Security News
The Socket Research Team has discovered six new malicious npm packages linked to North Korea’s Lazarus Group, designed to steal credentials and deploy backdoors.
Security News
Socket CEO Feross Aboukhadijeh discusses the open web, open source security, and how Socket tackles software supply chain attacks on The Pair Program podcast.