
Security News
PHP Foundation Says Chainguard Broke Security Embargo Ahead of Emergency Patches
The PHP Foundation says Chainguard broke a security embargo ahead of critical RCE patches, as leaks disrupted the coordinated release.
@lbug/lbug-wasm
Advanced tools
Ladybug is an embedded graph database built for query speed and scalability.
Ladybug-Wasm brings Ladybug to every browser thanks to WebAssembly.
Try it out at Ladybug-shell.netlify.app.
Prerequisite: Enable Cross-Origin-isolation
<script type="module">
import Ladybug_wasm from 'https://unpkg.com/@Ladybug/Ladybug-wasm@latest/dist/Ladybug-browser.js';
(async () => {
const Ladybug = await Ladybug_wasm();
window.Ladybug = Ladybug
const db = await Ladybug.Database()
const conn = await Ladybug.Connection(db)
await conn.execute(`CREATE NODE TABLE User(name STRING, age INT64, PRIMARY KEY (name))`)
await conn.execute(`CREATE (u:User {name: 'Alice', age: 35});`)
const res = await conn.execute(`MATCH (a:User) RETURN a.*;`)
const res_json = JSON.parse(res.table.toString());
})();
</script>
npm install @lbug/Ladybug-wasm
import Ladybug_wasm from '@lbug/Ladybug-wasm';
(async () => {
const Ladybug = await Ladybug_wasm();
const db = await Ladybug.Database()
const conn = await Ladybug.Connection(db)
await conn.execute(`CREATE NODE TABLE User(name STRING, age INT64, PRIMARY KEY (name))`)
await conn.execute(`CREATE (u:User {name: 'Alice', age: 35});`)
const res = await conn.execute(`MATCH (a:User) RETURN a.*;`)
const res_json = JSON.parse(res.table.toString());
})();
git clone https://github.com/LadybugDB/Ladybug-wasm.git --recursive
make package
| Subproject | Description | Language |
|---|---|---|
| Ladybug_wasm | Wasm Library | C++ |
| @Ladybug/Ladybug-wasm | Javascript API | Javascript |
| @Ladybug/Ladybug-shell | Cypher Shell | React |
By contributing to Ladybug-wasm, you agree that your contributions will be licensed under the MIT License.
FAQs
Ladybug GraphDB powered by WebAssembly
We found that @lbug/lbug-wasm demonstrated a healthy version release cadence and project activity because the last version was released less than a year ago. It has 1 open source maintainer collaborating on the project.

Security News
The PHP Foundation says Chainguard broke a security embargo ahead of critical RCE patches, as leaks disrupted the coordinated release.

Security News
PHP releases emergency patches for two critical RCE vulnerabilities as agencies urge organizations to take unpatched sites offline.

Threat Research
/Security News
A supply chain attack compromised LiteLLM 1.107.0 on PyPI and Docker, spreading malware that steals cloud credentials, developer secrets, and AI provider keys.