Socket
Socket
Sign inDemoInstall

dgeni-packages

Package Overview
Dependencies
Maintainers
1
Versions
147
Alerts
File Explorer

Advanced tools

Socket logo

Install Socket

Detect and block malicious and high-risk dependencies

Install

dgeni-packages - npm Package Compare versions

Comparing version 0.0.8 to 0.1.0

5

jsdoc/processors/doc-extractor.js

@@ -23,2 +23,7 @@ var path = require('canonical-path');

if ( !config.source.projectPath ) {
throw new Error('Missing configuration property.\n' +
'You must provide the path to the root of the project in `config.source.projectPath`');
}
injectables.value('projectPath', config.source.projectPath);

@@ -25,0 +30,0 @@ },

20

jsdoc/spec/processors/doc-extractor.spec.js

@@ -41,5 +41,23 @@ var Q = require('q');

it("should throw an error if the projectPath has not been set", function() {
expect(function() {
plugin.init({ source: { files: [] }});
}).toThrow();
});
it('should traverse the specified folder tree, reading each matching file', function() {
plugin.init({ source: { extractors: [mockNgDocExtractor, mockJsExtractor], files: ['./docs', './src'] }});
var config = {
source: {
projectPath: '.',
extractors: [mockNgDocExtractor, mockJsExtractor],
files: ['./docs', './src']
}
};
var injectables = {
value: function() {}
};
plugin.init(config, injectables);
plugin.process().then(function(docs) {

@@ -46,0 +64,0 @@ expect(docs.length).toEqual(4);

4

package.json
{
"name": "dgeni-packages",
"version": "0.0.8",
"version": "0.1.0",
"description": "A collection of dgeni packages for generating documentation from source code",

@@ -34,3 +34,3 @@ "scripts": {

"lodash": "~2.4.1",
"dgeni": "~0.0",
"dgeni": "~0.1.0",
"winston": "~0.7.2",

@@ -37,0 +37,0 @@ "doctrine": "~0.2.0",

SocketSocket SOC 2 Logo

Product

  • Package Alerts
  • Integrations
  • Docs
  • Pricing
  • FAQ
  • Roadmap
  • Changelog

Packages

npm

Stay in touch

Get open source security insights delivered straight into your inbox.


  • Terms
  • Privacy
  • Security

Made with ⚡️ by Socket Inc