Socket
Socket
Sign inDemoInstall

dgeni-packages

Package Overview
Dependencies
Maintainers
1
Versions
147
Alerts
File Explorer

Advanced tools

Socket logo

Install Socket

Detect and block malicious and high-risk dependencies

Install

dgeni-packages - npm Package Compare versions

Comparing version 0.9.2 to 0.9.3

jsdoc/spec/tag-defs/transforms/extract-type.spec.js

4

CHANGELOG.md

@@ -0,1 +1,5 @@

## v0.9.3 05/22/2014
* fix(extract-type): cope with missing type 4584a423
## v0.9.2 05/09/2014

@@ -2,0 +6,0 @@

2

jsdoc/spec/tag-defs/transforms/extract-name.spec.js
var Tag = require('../../../lib/Tag');
var transform = require('../../../tag-defs/transforms/extract-name');
describe("transform", function() {
describe("extract-name transform", function() {
var doc, tag, value;

@@ -6,0 +6,0 @@

@@ -54,2 +54,4 @@ // Much of this code was inspired by or simply copied from the JSDOC project.

return tag.description;
} else {
return value;
}

@@ -56,0 +58,0 @@ };

{
"name": "dgeni-packages",
"version": "0.9.2",
"version": "0.9.3",
"description": "A collection of dgeni packages for generating documentation from source code",

@@ -5,0 +5,0 @@ "scripts": {

@@ -82,9 +82,23 @@ # Dgeni Packages

* `api-docs` -
This processor runs a bunch of computations that are specifically related to docs for API components.
In particular, it will compute the package name for the module (e.g.
angular or angular-sanitize, it collects up all documents that belong to the module and
attaches them to the module doc in the `components` property, it computes the URL path to the document
in the docs app and the outputPath to the final output file, it relates documents about angular
services to their corresponding angular service provider document.
This processor runs computations that are specifically related to docs for API components. It does the following:
- Computes the package name for the module (eg angular or angular-sanitize)
- Collects up all documents that belong to the module
- Attaches them to the module doc in the `components` property
- Computes the URL path to the document in the docs app and the outputPath to the final output file
- It relates documents about angular services to their corresponding provider document.
api-docs has the following configuration options available (listed with the default values set):
```js
config.set('processing.api-docs', {
outputPath: '${area}/${module}/${docType}/${name}.html', // The path to write an api document's page to.
path: '${area}/${module}/${docType}/${name}', // The url for a document's page.
moduleOutputPath: '${area}/${name}/index.html', // The path to write an api module's page to.
modulePath: '${area}/${name}' // The url for a module's page.
}
});
```
* `component-groups-generate` -

@@ -91,0 +105,0 @@

SocketSocket SOC 2 Logo

Product

  • Package Alerts
  • Integrations
  • Docs
  • Pricing
  • FAQ
  • Roadmap
  • Changelog

Packages

npm

Stay in touch

Get open source security insights delivered straight into your inbox.


  • Terms
  • Privacy
  • Security

Made with ⚡️ by Socket Inc