New:Introducing Socket Scanning for VS Code Marketplace Extensions.Learn more →
Get Started
m

microshine

npm

469.24M

total weekly downloads

Packages

Current Co-maintainers

Former Co-maintainers

99 packages

2key-ratchet

2key-ratchet is an implementation of a Double Ratchet protocol and X3DH in TypeScript utilizing WebCrypto.

@acme-ra/client

JavaScript/TypeScript client library for the ACME API

@acme-ra/protocol

JavaScript/TypeScript client library for the ACME API

asn1js

asn1js is a pure JavaScript library implementing this standard. ASN.1 is the basis of all X.509 related data structures and numerous other protocols used on the web

bytestreamjs

ByteStream is a library making possible to manipulates single bytes and bits on pure JavaScript

dhcp-mon

NodeJS implementation of DHCP socket connection

fontjs

Parse, edit, subset and write TrueType fonts

graphene-cli

graphene-pk11 CLI

graphene-pk11

A simple layer for interacting with PKCS #11 / PKCS11 / CryptoKI for Node in TypeScript

node-webcrypto-ossl

A WebCrypto Polyfill for Node in TypeScript built on OpenSSL

node-webcrypto-p11

A WebCrypto Polyfill built on PKCS11

@peculiar/acme-client

Client for the Automatic Certificate Management Environment (ACME, RFC 8555).

@peculiar/acme-core

Errors, HTTP content and logging shared by the Automatic Certificate Management Environment (ACME, RFC 8555) packages.

@peculiar/acme-data

Data model and repository interfaces of the Automatic Certificate Management Environment (ACME, RFC 8555) server.

@peculiar/acme-data-dynamodb

DynamoDB data layer for the Automatic Certificate Management Environment (ACME, RFC 8555) server.

@peculiar/acme-data-memory

In-memory data layer for the Automatic Certificate Management Environment (ACME, RFC 8555) server.

@peculiar/acme-express

Express middleware that serves the Automatic Certificate Management Environment (ACME, RFC 8555) protocol.

@peculiar/acme-protocol

Protocol objects of the Automatic Certificate Management Environment (ACME, RFC 8555).

@peculiar/acme-ra

Express registration authority for the Automatic Certificate Management Environment (ACME, RFC 8555) with External Account Binding using Bearer tokens and several Certificate Authority endpoints.

@peculiar/acme-server

Server services and controller of the Automatic Certificate Management Environment (ACME, RFC 8555), independent of the HTTP framework.

@peculiar/asn1-adobe-acrobat

ASN.1 schema for Adobe Acrobat DC digital signature OIDs and X.509 extensions.

@peculiar/asn1-android

ASN.1 schema for Android key attestation extensions, including legacy Keymaster and newer KeyMint structures.

@peculiar/asn1-apple

ASN.1 schema for Apple App Attest nonce extensions.

@peculiar/asn1-asym-key

ASN.1 schema for asymmetric key packages and OneAsymmetricKey structures defined in RFC 5958.

@peculiar/asn1-cert-transparency

ASN.1 schema for Certificate Transparency structures and signed certificate timestamp data defined in RFC 6962.