New:Introducing Socket Scanning for VS Code Marketplace Extensions.Learn more →
Get Started
p

peculiarventures

npm

435.50M

total weekly downloads

Packages

Current Co-maintainers

Former Co-maintainers

92 packages

asn1js

asn1js is a pure JavaScript library implementing this standard. ASN.1 is the basis of all X.509 related data structures and numerous other protocols used on the web

bytestreamjs

ByteStream is a library making possible to manipulates single bytes and bits on pure JavaScript

cadesjs

CAdESjs gives you an ability to make CAdES signatures on pure JavaScript. The libray made with latest CAdES standards in mind

fontjs

Parse, edit, subset and write TrueType fonts

graphene-pk11

A simple layer for interacting with PKCS #11 / PKCS11 / CryptoKI for Node in TypeScript

node-webcrypto-ossl

A WebCrypto Polyfill for Node in TypeScript built on OpenSSL

node-webcrypto-p11

A WebCrypto Polyfill built on PKCS11

padesjs

ES6 version of PAdESjs

@peculiar/acme-client

Client for the Automatic Certificate Management Environment (ACME, RFC 8555).

@peculiar/acme-core

Errors, HTTP content and logging shared by the Automatic Certificate Management Environment (ACME, RFC 8555) packages.

@peculiar/acme-data

Data model and repository interfaces of the Automatic Certificate Management Environment (ACME, RFC 8555) server.

@peculiar/acme-data-dynamodb

DynamoDB data layer for the Automatic Certificate Management Environment (ACME, RFC 8555) server.

@peculiar/acme-data-memory

In-memory data layer for the Automatic Certificate Management Environment (ACME, RFC 8555) server.

@peculiar/acme-express

Express middleware that serves the Automatic Certificate Management Environment (ACME, RFC 8555) protocol.

@peculiar/acme-protocol

Protocol objects of the Automatic Certificate Management Environment (ACME, RFC 8555).

@peculiar/acme-ra

Express registration authority for the Automatic Certificate Management Environment (ACME, RFC 8555) with External Account Binding using Bearer tokens and several Certificate Authority endpoints.

@peculiar/acme-server

Server services and controller of the Automatic Certificate Management Environment (ACME, RFC 8555), independent of the HTTP framework.

@peculiar/asn1-adobe-acrobat

ASN.1 schema for Adobe Acrobat DC digital signature OIDs and X.509 extensions.

@peculiar/asn1-android

ASN.1 schema for Android key attestation extensions, including legacy Keymaster and newer KeyMint structures.

@peculiar/asn1-apple

ASN.1 schema for Apple App Attest nonce extensions.

@peculiar/asn1-asym-key

ASN.1 schema for asymmetric key packages and OneAsymmetricKey structures defined in RFC 5958.

@peculiar/asn1-cert-transparency

ASN.1 schema for Certificate Transparency structures and signed certificate timestamp data defined in RFC 6962.

@peculiar/asn1-cms

ASN.1 schema for Cryptographic Message Syntax (CMS) defined in RFC 5652.

@peculiar/asn1-crmf

ASN.1 schema for Certificate Request Message Format (CRMF) defined in RFC 4211.

@peculiar/asn1-csr

ASN.1 schema for PKCS #10 certificate signing requests defined in RFC 2986.