A library for runtime type checking and validation of python values
Data validation using Python type hints
Core functionality for Pydantic validation and serialization
An implementation of JSON Schema validation for Python
The JSON Schema meta-schemas and vocabularies, exposed as a Registry
A robust email address syntax and deliverability validation library.
Validate configuration and produce human readable error messages.
A non-validating SQL parser.
A pure python RFC3339 validator
Modern, type-safe OpenAPI schemas in Python using Pydantic 1.8+ and 2.x
Python version of Google's common library for parsing, formatting, storing and validating international phone numbers.
Pure python rfc3986 validator
Validate and standardize array-like input.
Python Data Validation for Humans™
OpenAPI schema validation for Python
OpenAPI 2.0 (aka Swagger) and OpenAPI 3 spec validator
Validating URI References per RFC 3986
Simple data validation library
Always know what to expect from your data.
pathvalidate is a Python library to sanitize/validate a string such as filenames/file-paths/etc.
GenSON is a powerful, user-friendly JSON Schema generator.
Clean, filter and sample URLs to optimize data collection – includes spam, content type and language filters.
Form validation and rendering for Python web development.
Google Maps Addressvalidation API client library
A light-weight and flexible data validation and testing tool for statistical data objects.
Form rendering, validation, and CSRF protection for Flask with WTForms.
A high-performance JSON Schema validator for Python
Python version of Google's common library for parsing, formatting, storing and validating international phone numbers.
An XML Schema validator and decoder
Python data validation library
A python library to define and validate data types in Docling.
A comprehensive I/O validator for electronic structure calculations
Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)
Validates X.509 certificates and paths; forked from wbond/certvalidator
Config file reading, writing and validation.
DocLang reference toolkit
A Python library for automatically generating Pydantic v2 models from JSON Schema definitions
Lightweight, extensible schema and data validation tool for Pythondictionaries.
A library to perform runtime validation of Python objects using type hints.
typepy is a Python library for variable type checker/validator/converter at a run time.
USD Validation NVIDIA
Python lib/cli for JSON/YAML schema validation
Protocol Buffer Validation for Python
A schema and validator for YAML.
A library for exploring and validating machine learning data.